Member Login

WIN a $100 Voucher

iinet

iinet Review
 
 

Adamcontencin
Posted: January 24, 2016 - 12:40:00 PM

Posts: 1
Joined: January 23, 2016

Plan Name: Naked Home Value V3
Broadband Type: ADSL2+
Monthly Cost: $59
Activation Time: 2 weeks

Speed: 5%
Reliability 5%
Tech Support: 5%
Presales Info: 50%
Features: 50%
Value: 5%
Overall: 20%

Pros: None now
Cons: Unreliable, Slow, Terrible Tech Support

Comments:
We signed up with iiNet a bit over two years ago and they were fine, we were connected in fair time from memory, the internet speed was pretty good, the customer support was pretty good, we were pretty happy.

Early in 2015 we signed up for Stan. and, despite our speed supposedly being slower than "recommended" for HD, it streamed seamlessly most of the time. Late last year, maybe September or October, I started to notice the internet was being disconnected a couple of times a week, but it reconnected within a minute or two so I wasn't too bothered. However, one day it was dropping out every hour, and sometimes taking up to 10 minutes to reconnect. I emailed tech support and got a call back the next day while I was at work. I'll paraphrase: "Hi, can you look at your modem", "No I'm at work", "What time will you be home", "In four hours", "No problem, I'll call you back then", "Great". I never got a call back but the connection seemed to stablise so I just left it.
Since then we have had irregular outages, up to 5 and 6 hours at a time, which really sucks if you are tying to complete a Uni degree online. We were recently disconnected for an entire Friday. I rang tech support and was on hold so left a call back request. An hour or so later we got a call back, ran through the usual things, power cycled the modem (which I had already done a few times - I'm not an idiot) then he did a ping test and remotely changed something and said my modem was a little bit faster "Is the internet on now?", "No". All the while he was muttering something to himself or just complete silence, at one point I was just waiting for 15 minutes. Tech Support: "I need to try some things, I'll call you back in 20 minutes?", "Ok, great". After an hour, and still disconnected, I called back "Yeah there is an outage in your area, it will be fixed by tomorrow". The next day, 2pm, still no internet, called tech support again, recorded message: "There was an outage for some WA customers this morning, if you haven't been reconnected power cycle your modem". I already did that (not an idiot) "The current wait time is more than an hour", so I requested a call back. 11.50pm *phone rings, I push power.
Internet is still rubbish, I'm currently getting 20-200KB/sec (who even know what this means? - Firefox estimates at 200KB it's going to take another 2 and a half hours to download 900Mb).
I have left a request ticket with Internode to see how quickly they can relieve me of the burden of iiNet.